2012. március 8., csütörtök

NetBeans 7.1 - megéri váltani?

Tegnap érdekes problémára derült fény.

A NetBeans 7.1beta-val készített projektet átültettem, hogy a 7.1-ben is fusson, de újabb gond akadt. NB-ből futtatva gyönyörűen megy, viszont az elkészített JAR fájl futtatáskor nem találja a lib-eket. A probléma a jar/META-INF/manifest.mf fájljában leledzik, ami tárolja azt a classpath-t, amit a JAR fájl használ futáskor.

A NB 7.1-es verziója konkrétan elfelejti definiálni a "JavaFX-Class-Path" értéket a manifest fájlban. Voltam olyan eszes, hogy backupoltam a 7.1beta-val készített JAR-t, így azzal össze tudtam hasonlítani, innen derült fény a turpisságra. (És azt, hogy melyik fájlban lehet gond, a témavezetőm mondta, úgyhogy innen is köszönet neki!)

Lehetséges konklúzió: maradjunk meg a NetBeans 7.1beta-nál? (És nézzük el, hogy néha exception-t dob a lassúság-detektora?)

A hibát még a 7.1.1-es verzióban sem javították.